Build 0.0.14 Feedback

  • I'm doing something new by typing this out as I go through the game so it might be jumpy. Also, if you want a summary of what I thought of the game, I have a TL:JWF at the bottom.

    The intro is nice, telling us about the history so things tie together, but it will only keep going if I click in the actual text area. I was keeping my mouse way out of the way so it wouldn't be distracting, but it wouldn't go on until I clicked in the text area.

    Got to the dream scene and explored a tiny bit before the spawns came in. Thought I could just go around them like in the previous build to see how big the area is, but when trying to go back got completely killed before getting to where I started. I more blame myself trying to explore and not take the hint when the spawns were way too far ahead to try outrunning the creatures.

    Now at home, getting the main talk from Dwerv's father. Pressed a couple buttons to move the text along, but apparently only space works (found that quickly at least). Still like the story setup.

    Doing the tutorial on "How to be a Warsmith". Just got the spinner turret and the info box that pops up had the mouse icon on it as well. Just a little bit distracting, but I wasn't using the mouse at all. The shadow-turret where it shows you were to put it still to me seems to disappear way too quickly. Maybe if there was a slight fading transition so that I know it is disappearing or just have it dissapear when I am right on the spot for the turret would be nice.

    Birds on the log when you start going out. Nice touch! Also tested out the turret on the first slimes. Feels so good being able to take swarms. Also just noticed that the icon colors change when it's about to spawn baddies, and it isn't hooked up to the timer. It seems to change color when they will spawn in... 3 seconds? That was very handy when figuring out when I should remake my turret.

    Just got to the bridge and found a problem, one of the bees wasn't close enough to the turret to get hit, but was able to attack it still. Not sure if the turret was too close so it didn't need to even move or just a strange once-in-a-blue moon chances, but I was able to still pass it after taking some hits. I didn't get the picture of it attacking, but it was this bridge.

    Bridge bug spot.png

    Those color warning really helped with the main fight in front of the... pub? brew storage?... I forgot. Aerie is still cute! Not sure how he knew I was using turrets while he was stuck in a building and stuffed with honeydew ale, but I'm probably overthinking it. Probably just looked out the window.

    Just noticed that your grandpa tells you how to control which turret gets taken down when he gives you the other two power stones. I just figured it out on my own the previous times. Good thing I listned too, because it seems to be which one is closest to where you are facing and not just the closest one.

    FLOWER SPIDERS!!!... also tried cutting wheat again. no luck.

    Just saw the orcs. Devious little plan. I always found it strange that they talk about their plan while facing you, yet never notice you. O well, need to fight these boars... and took a big beating from them too. Didn't notice the one that spawned behind me.

    ... Hold on, Dwerv's father knows about the turrets too? So what part of the fade-into-myth-and-bedtine-stories is the part people no longer believed? Or is Dwerv's family the only ones left that remember it? I can get grandpa since he had the power stones and the workshop. I can get Aerie since I assume he's Dwerv's grampa's pet. But his father too?

    The boomerang is back! Didn't expect it to come back since this is mainly about turrets, but I wonder if this means breakable boxes are back too.

    ... That was a close one. You guys ramped up the difficulty on this one. This definitely felt like a major challenge.

    Close one.png

    ... I want to smack that chieftain. Not believing the ones that actually stayed back. Not to mention that there are also no Elfairie bodies either... speaking of which, I haven't really seen any sign of a battle. Also considering that Dwerv's dad was the only one left behind, I'm surprised that they needed to send pigs in to eat the bodies. He could have just stood there and fought all the pigs at... I'm going to stop criticizing the story, we are here for gameplay, not nit-picking a story apart.

    Whew, my health healed up going into the next zone. was worried I'd have to do the rest with just 1 hitpoint. Good thing too. Now I know these arrow turrets are fragile. The bees took out one of them. Luckily that gave me some gems to put down a spinner turret for the boars to fight. Also feels strange trying to be close to the fight now that I have a boomerang to help take down enemies.

    Got the key! Found the treasure, and inside was... armor and some gears? I can get the gears, they seem to be the currency in this world, but what do I do with the armor? In fact, where did it go?

    And now just leaned that boars outrun arrows. need to remember that.

    Well, this island was interesting:

    Island fight.png

    Thought I could put crossbows on the two divots on the outside. Nope, first wave boars. Went with the bow-and-spinner tactic which turned out really well. Didn't even get hit. Really helps that bees go after anything that is close to them, so just make sure you put a spinner in their way and everything should turn out well.

    ... Is this a bug (no pun intended, but very fitting). These spiders aren't chasing me.

    Bug bug.png

    Used this time to test out power of my crossbow and boomerang... for some reason the boomerang is stronger.

    ... Had to stop for now, will add on when after a good night's rest.

    Good rest, now back to Dwerve.I knew it wasn't going to save my progress since this is an alpha, so this is a good time to test some more things out.

    Played the intro again. Decided to do it the "intended" way and run from anything that spawned. First thing I get is boars. Tried going down another path, but the boars caught up to me very quickly and liked me before I can even see if I could go down there. Felt more like I lost a race instead of being surrounded.

    Back at home, I decided to do some exploring and see the place around the house before getting trained. Nice touch of having some dialog for the clothes so I know you don't mind people exploring a bit. Found out I could go around the house... or more behind the house. Got all the way up to here and stopped by some water. Just fill in that square there and I wouldn't have to do a "long" trek back around.

    House trouble.png

    Things going normal so far, and unfortunately ran into that same thing where the bee can out range my spinner turret. Different spot this time too. I still wasn't able to get a picture, but now I'm thinking that it can barely outreach it if in the right spot. Other than that, this going pretty smoothly. The spiders that were bugs the last time worked now as well, so I don't know what happened.

    Finally to where I left off last time... How does the merchant even know about turr... wait, he's been watching me. That's probably it. Really need to stop nit-picking the story.

    ... HOLD ON A MINUTE I WAS LITERALLY RIGHT AT THE END?!?!... O well. At least I got to see some other stuff like if that glitch was permanent and whatnot.

    Here is some TL:JWF (Too long, just want feedback)

    • The intro went from being able to explore every nook and cranny before the enemies could even hit you to I can barely move anywhere without one catching up and killing me. Needs to be at least some balance so that people can't get to the edge but you properly get surrounded before you get smacked.

    • I really like the approach of the tutorial on how you learn the controls and then just go out and test it. Maybe you should have the gameplay text in a different color so that we can better see what is the story and what we should know.

    • Everything is at least manageable. Haven't died once, but got pretty close to dying a couple times, and this is from someone who played this a couple times.

    • Double check the range of the beefairies because it seems like their range is equal to the spinner and they can get in the right spot with some luck to hit it without my turret hitting it back.

    • There is one main hole in the story that the warsmiths and trolls turned into fairy tales and yet almost everyone knows about them. The chieftain is the only one that doesn't know that trolls are real, and I'm not sure if he knows about turrets.

    • Put some bodies in the town so that it seems like there was a fight going on. It looked like they just destroyed the village while (almost) everyone was away, but they sent in pigs to eat the corpses. At least some blood stains not from the pigs would work.

    Sorry about the last two, I am a person that loves the stories in games and those were some big holes.

  • Scubadoo, I'm revisiting old posts I never replied to (but did read!!) and I just wanted to first thank you for taking the time to playtest our game and provide such thorough feedback. Peter and I have since addressed many of these issues, but others still remain on our to-do list. We have spent the last two months or so preparing for our Kickstarter so have been busy with that. But we plan to get back to full speed development later this fall. Thanks again for taking the time to be a part of development ❤

Log in to reply